Jan 192010
 

How to upgrade perl to v5.8.8

Running cPanel 11 requires you to have perl v5.8.8. If you run an older version some things will not work properly (like spamassassin for example).

Do you need to upgrade? If you running an older version, then Yes. How to check what version are you using?
Run:

perl -v

If you see something like:

This is perl, v5.8.7 built for i686-linux

then you need to upgrade.

Upgrading is simple because I have seen a few problems in the past related to this.

1. Download the cPanel perl installer

wget http://layer1.cpanel.net/perl588installer.tar.gz

2. Extract the archive

tar zxvf perl588installer.tar.gz

3. Run the installer

cd perl588installer
./install

4. Check perl modules

/scripts/checkperlmodules

5. Force a cPanel update

/scripts/upcp –force

6. Update perl information in user’s cPanel

rm -rf /home/*/.cpanel;rm -rf /home/*/.cpanel-datastore

7. Check the actual new perl version

perl -v

This should now output something like:

This is perl, v5.8.8 built for i686-linux

 Posted by at 10:04 am

 Leave a Reply