Mar 242013
 

Howdy,

Apparently some recent cPanel shenanigans have caused problems on some systems with the Perl Module Scalar::Utils. It appears that it may have been modified, removed or something similar. If this is the case, you may see cpan installs failing, EasyApache installs failing, /scripts/perlinstaller installs failing, and more.

The errors will look something like:

Undefined subroutine &Scalar::Util::blessed called at /usr/lib/perl5/5.8.8/JSON/PP.pm line 319.

Reinstalling this module is rather interesting as it appears that once you start, the module requires itself to continue the install. Re-installing the Perl RPM does not fix this. It is prevalent enough that cPanel’s written a fix for it:

/scripts/autorepair scalarutil

Run that, and run the perlinstaller afterwards to check your work with:

/scripts/perlinstaller --force Task::Cpanel::Core

And you should be good.

Share This!
 Posted by at 4:08 pm

Sorry, the comment form is closed at this time.