Dec 152009
 

You should be able to use the most recent versions of cPanels version of EasyApache to install IonCube. If not The below procedures will work. This script will do the same thing as described below. ioncube_install.sh

uname -a

to determine if x86_64 or x86 then get source from http://www.ioncube.com/loaders.php. Copy the link location of the file you want to download

cd /usr/local

wget http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86.tar.gz

tar -xvzf ioncube_loaders_lin_x86.tar.gz

copy /usr/local/ioncube/ioncube-loader-helper.php into some public_html dir on server

go to the location of the file you just copied into the public_html folder via a browser and click on php.ini installation instructions link and then follow the instructions to add proper line to php.ini file. You will then need to restart apache and then click the back button in the browser and click on run-time loading installation instructions. If the results say:

An ionCube Loader is already installed and run-time loading is unnecessary.

Encoded files should load without problems and you should be good to go.

 Posted by at 8:03 am

 Leave a Reply