CloudLinux PHP Issue

Categories General Info

There seems to be an issue with Cloud Linux and Alt-PHP (which seemed to be limited to servers which ran updates to EA4 last night) — Symptoms may include AltPHP versions not seeming to load extensions such as PDO… 

This looks to be a problem with the updates to ea-apache24-mod_suphp we released last night. The phprc was changed and is causing issues where PHP loads modules from, specifically regarding alt-php versions running suphp as the handler. Until this can be corrected, downgrading ‘ea-apache24-mod_suphp’ is the current workaround. This will allow the websites to load the proper modules and stay on alt-php packages. 

yum downgrade ea-apache24-mod_suphp

IF that fails, do

yum clean && yum downgrade ea-apache24-mod_suphp

This is a workaround until updates are issued. 

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.