Updating Java to 1.8.0

Categories General Info

Howdy ma Peeps!

Long time no post!

I recently ran into an issue with a client trying to update OpenJDK to 1.8.0 (using the “yum install java-1.8.0”) to his cPanel server (CenotOS 6.9 WHM v68.0.23) which failed with the error that it requires (Network Security Services) nss >= 3.28.4 (and the server is running nss 3.21.0).

In attempting to update nss, it looks as though there are exclusions in the yum.conf file which blocks the server from updating nss:

exclude=bind-chroot courier* dovecot* exim* filesystem httpd* mod_ssl* mydns* mysql* nsd* nss* p0f perl* php* proftpd* pure-ftpd* ruby* spamassassin* squirrelmail*

Once removed, the OpenJDK update completed without error.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.